Forum di "Stampa 3D e molto altro!"

La Risorsa italiana per Makers

Discussioni sulle parti elettriche ed elettroniche, motori, endstop, etc. Parliamo di struttura della stampante, pulegge, madreviti, boccole, viti trapezoidali, etc.
#212
Ciao a tutti!

La nostra smartrapcore sta prendendo vita piano piano, stiamo cercando di capire come funziona bene il tutto e quindi avrei un paio di domande. Una di questi è un problema da risolvere.

Iniziamo pure con le assi X e Y: per chi conosce la stampante sa che i motori per X e Y non sono chiari da definire nel senso che le assi si muovo attraverso il movimento coordinato di entrambi i motori collegati a doppia cinghia..
Ora stiamo provando a utilizzare il controllo manuale delle assi da Simplify3d

Immagine

Dando il comando all'asse X o all'asse Y il movimento però avviene in diagonale.
Noi abbiamo pensato che il comportamento sia corretto perchè giustamente Simplify non sa in quel momento com'è fatta la nostra stampante, ma dandogli uno di quei comandi andrà a muovere solo un motore. Vi torna questa cosa?

Un'altra domanda riguardava gli endstops: dopo svariate prove dovremmo averli impostati correttamente, ma è giusto che appena vengono toccati ci sia una specie di "saltello" per staccarsi dall'endstop?

Ora arriviamo al problema principale, l'asse Z: oltre a fare un casino madornale(che crediamo sia dovuto alla sua posiziona particolare) dandogli un comando dal +1 in su il piatto fa uno scatto veloce e poi è come se il motore girasse a vuoto. Abbiamo provato ad allentare la cinghia di un dentino: così facendo il problema sembra diminutio, ma il movimento sembra essere tropo veloce e la cinghia ci sembra davvero troppo molle.

Scusate per la lunghezza del post, spero di essere stato il più chiaro possibile! Ho un video, ma è lunghissimo e non ho tempo di tagliarlo con i momenti interessati a questi problemi(soprattutto su x e y). Se volete posso pure caricarlo su youtube.

Grazie mille! :)
Avatar utente
da neolinux
#215
Ciao,

se in Simplify3d (o altro software) avete impostato che la stampante e' una corexy allora non deve assolutamente usare uno stepper alla volta. Deve usarli entrambi in modo da muovere in modo corretto lo jhead.

Il problema indicato potrebbe derivare da cinghie troppo strette o troppo allentate, dai polulu non tarati bene/rotti, da qualche cavo che vi da noia o da un'impostazione steps/mm errata. Avete caricato QUESTO Firmware?

Per quanto riguarda l'asse z, credo dipenda dagli steps/mm configurati nel firmware. Spianate tutto e ricaricate il firmware di Serge.
#219
neolinux ha scritto:Ciao,

se in Simplify3d (o altro software) avete impostato che la stampante e' una corexy allora non deve assolutamente usare uno stepper alla volta. Deve usarli entrambi in modo da muovere in modo corretto lo jhead.

Il problema indicato potrebbe derivare da cinghie troppo strette o troppo allentate, dai polulu non tarati bene/rotti, da qualche cavo che vi da noia o da un'impostazione steps/mm errata. Avete caricato QUESTO Firmware?

Per quanto riguarda l'asse z, credo dipenda dagli steps/mm configurati nel firmware. Spianate tutto e ricaricate il firmware di Serge.


Grazie per la risposta ;)
Probabilmente non abbiamo configurato simplify come corexy, non lo sapevamo!
Il firmware dovrebbe essere quello, per sicurezza lo ricarichiamo però.

È strano quello che fa l'asse Z più che altro.

Inviato dal mio Nexus 4 utilizzando Tapatalk
Avatar utente
da neolinux
#221
Fate un video e postatelo qui, cosi vedo di capire meglio cosa esattamente fa o non fa. Io avevo un fenomeno simile quando cambiai l'asse Z da cinghia a barra filettata. Ho risolto cambiando gli steps/mm.
#223
neolinux ha scritto:Fate un video e postatelo qui, cosi vedo di capire meglio cosa esattamente fa o non fa. Io avevo un fenomeno simile quando cambiai l'asse Z da cinghia a barra filettata. Ho risolto cambiando gli steps/mm.

E gli steps da dove li cambi?
E il tipo di stampante da simplify invece?

Inviato dal mio Nexus 4 utilizzando Tapatalk
Avatar utente
da neolinux
#224
Gli steps/mm li cambi nel firmware, per simplify3d non ricordo dove si faceva, ma puoi usare il profilo che ho postato sul. Forum, quello funziona sicuro perché è testato.

Inviato dal mio C6903 utilizzando Tapatalk
#225
neolinux ha scritto:Gli steps/mm li cambi nel firmware, per simplify3d non ricordo dove si faceva, ma puoi usare il profilo che ho postato sul. Forum, quello funziona sicuro perché è testato.

Inviato dal mio C6903 utilizzando Tapatalk

Ma allora ci dovrebbe già funzionare, perché noi avevamo il tuo profilo caricato.

Però effettivamente non funziona, quindi ci sarà un altro punto.
A te funzionava il controllo manuale?

Inviato dal mio Nexus 4 utilizzando Tapatalk
Avatar utente
da TrapInsanity06
#227
neolinux ha scritto:Sinceramente non l'ho mai usato il controllo remoto da Simplify3d. Generavo solo i gcode e poi li davo in pasto a octoprint.

Inviato dal mio C6903 utilizzando Tapatalk


Ah ok, da come parlavi sembrava di sì e per questo andavo sul sicuro!
Secondo me il controllo manuale allora, come dicevo nel primo post, non riesce a gestire al meglio questa cosa.

Inoltre Pasquale, la tua stampante faceva molto rumore?
Avatar utente
da Balza
#229
TrapInsanity06 ha scritto:Ah ok, da come parlavi sembrava di sì e per questo andavo sul sicuro!
Secondo me il controllo manuale allora, come dicevo nel primo post, non riesce a gestire al meglio questa cosa.

Inoltre Pasquale, la tua stampante faceva molto rumore?


A Simplify3D interessa solamente sapere se generare il g-code per una cartesiana o una delta, perchè in fin dei conti è quello che discrimina lo slicing. Non gli interessa come il tuo hotend raggiungerà i vari punti sul piano. Quello viene definito all'interno del firmware; ovviamente se hai una CoreXY deve essere abilitato all'interno del Marlin, ma credo che, caricando il firmware consigliato da neolinux, non avrai problemi.

Si, le parti in movimento tornano indietro dopo aver toccato l'endstop, per poi ritornare a toccarlo più lentamente (non so se sia per una rilevazione più corretta o per evitare di sforzare troppo sullo stesso).

Il rumore dell'asse Z potrebbe dipendere dalla posizione della stampante. E' contenuto dentro la scatola di legno della stampante stessa che è posta sopra al tavolo di legno del GULLP. Non conoscendo l'entità del rumore non posso dirlo con certezza (ti invito a caricare il video su YouTube e condividerlo qui nel forum), prova ad appoggiarla su di un piano assorbente. Potrebbe anche dipende dal fatto che il motore sia bloccato dalla troppa tensione della cinghia o dalla bassa Vref del pololu.

TALLINN, Estonia -- Three thoughts on Europa Leagu[…]

It would, of course, be silly to draw conclusions […]

It's a strong bet that those trying to assess how […]

They are not striking similarities as much as supe[…]

Seguimi su YouTube!